centos7 yum与Python3冲突!!

虽然标题不严谨,但是,我自己尝试了多次,在安装了Python3.6后,yum无法同步Python。所以采用网上抄来抄去的做法,将yum指定使用Python2,凡是需要安装与Python相关的模块,使用pip。

安装Python和pip的方式与Ubuntu一样(yum不同步,只能离线安装pip)http://www.32069.cn/post-24.html

 

/usr/bin/yum是yum的执行程序,打开发现是一个Python文件。首行可以直接看到它使用的Python来源,修改为Python2即可。如果后面yum使用仍然报什么文件执行失败,应该是那个文件(也是Python实现的,这是另一个文件,名字我忘了)里python版本需要制定2。

本博客所有文章如无特别注明均为原创。作者:小乐复制或转载请以超链接形式注明转自 众众帮
原文地址《centos7 yum与Python3冲突!!
分享到:更多

相关推荐

发表评论

路人甲 表情
Ctrl+Enter快速提交

网友评论(0)